Hamina Wireless - Disruption in Hamina US services – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
Report an issue
Get updates
All systems operational
Disruption in Hamina US services
Resolved
Operational
Started 21 days ago
Lasted 6 minutes
Affected
Hamina app (US region)
Major outage from 3:04 AM to 3:10 AM
Updates
Resolved
May 12, 2025 at 03:10 GMT+0
Resolved
May 12, 2025 at 03:10 GMT+0
This incident has been resolved.
Identified
May 12, 2025 at 03:04 GMT+0
Identified
May 12, 2025 at 03:04 GMT+0
We are continuing to work on a fix for this incident.